Press enter to see results or esc to cancel.

IDN (Internationalized Domain Names) Nedir?

Sunucuma geçenlerde bir alan adı tanımlamak zorunda kaldım baktım ki türkçe karakterler içeriyor. Biraz araştırdım ve sizlerle paylaşmak istedim.
Internationalized Domain Names (IDN) milletlerarası alan adları anlamına gelen bu kavram ASCII karakterleri içermeyen alan adlarıdır.Standart alan adları a-z, 0-9 ve – karakterlerinden başka bir karakter içeremez. Bu da biraz kısıtlı olmamıza neden oluyor. IDN Unicode ile verilmiş algoritmayı ASCII standartlarına çevirir.
Örnek vermek gerekirse, tarayıcımıza www.çşiğü.com.tr yazdığımızda tarayıcımız IDN standartlarına göre bu karakterlerin ASCII karşılığını bulur ve dns ‘e normal bir ASCII karaktermiş gibi sorgu gönderir. Bu da çşiğü.com.tr adresini tarayıcıda farklı karakterler olarak göreceğimiz anlamına gelir. çşiğü.com.tr alan adını tarayıcımızda girdiğimizde xn--i-5fa8d5g4m.com.tr olarak ASCII karakterlerine dönüştüğünü görürüz.
Dns veya Web Server ‘da bu tür alan adlarını girmek için alan adlarını ASCII formatına çevirmemiz gerekir. Bunun için aşağıdaki adresleri kullanabilirsiniz.

https://www.nic.tr/index.php?&USRACTN=IDNCNVRT
http://mct.verisign-grs.com/conversiontool/index.shtml

Kolay gelsin dileğiyle.

Cisco 1841 Adsl Konfigurasyonu

Cisco 1841 ile adsl konfigurasyonu asagidaki gibidir,

murat>enable
murat#conf terminal
murat(config)#int ATM ATM 0/0/0
murat(config-if)#no ip address
murat(config-if)#dsl operating-mode auto
murat(config-if)#pvc 8/35
murat(config-if-atm-vc)#pppoe-client dial-pool-number 1
murat(config-if-atm-vc)#exit-vc
murat(config-if)#no shutdown
murat(config)#int dialer 0
murat(config-if)#ip address negotiated
murat(config-if)#encapsulation ppp
murat(config-if)#dialer pool 1
murat(config-if)#ppp authentication pap callin
murat(config-if)#ppp pap sent-username kullanici@ttnet password sifre
murat(config-if)#ppp ipcp dns request
murat(config-if)#ip nat outside
murat(config-if)#mtu 1500
murat(config-if)#exit
murat(config-if)#ip route 0.0.0.0 0.0.0.0 dialer0
murat(config)#interface FastEthernet 0/0
murat(config-if)#ip address 192.168.1.1 255.255.255.0
murat(config-if)#ip nat inside
murat(config)#access-list 101 permit ip 192.168.1.1 0.255.255.255 any
murat(config)#ip nat inside source list 101 interface dialer0 overload
DHCP icin
murat(config)#ip dns server
murat(config)#ip dhcp pool clients
murat(dhcp-config)#import all
murat(dhcp-config)#network 192.168.1.0 255.255.255.0
murat(dhcp-config)#default router 192.168.1.1
murat(dhcp-config)#dns-server 195.175.39.40 195.175.39.39 212.175.105.35

Yardimlarindan dolayi Sayin Genco YILMAZ ‘a tesekkur ederim.
NOT : Cisco 877 Modelin de ayni konf. kullanabilirsiniz.

Acrobat Reader : expr: syntax error hatasına çözüm

Acrobat Reader ‘da expr: syntax error şeklinde hata alıyor ve açılmıyorsa aşağıdaki gibi /usr/bin/acroread dosyasını editlemeniz gerekiyor.

418 ‘cı satırda bulunan echo $mfile| sed ‘s/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g’ satırını
echo $mfile| sed ‘s/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]*\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g’ şeklinde değiştiriyoruz

643 satırda bulunan MIN_GTK_VERSION=”240″ satırını
MIN_GTK_VERSION=”2040″ şekilde değiştiriyoruz.

Yum Nasıl ?

Yum : Yellow dog Updater, Modified

Yum otomatik paket güncelleme ve yükleme/silme işlemlerini yapan rpm tabanlı bir sistemdir.

Yum Komutları:
Paket yüklemek için,
yum install paket_adı > yum install xmms
Paket kaldırmak için,
yum remove paket_adı > yum remove xmms
Paket güncellemek için,
yum update paket_adı > yum update xmms
Mevcut yüklenebilir paketleri listemek için,
yum list available
Kurulmuş bütün paketleri güncellemek için,
yum update
Hangi paketlerin güncel sürümlerinin çıktığını görmek için,
yum check-update
Depolarda paket araması yapmak için,
yum search paket_adı > yum search xine
Yüklenmiş paketleri görmek için,
yum list installed

Yum, gücelleme veya yükleme işlemlerinde paketleri /var/cache/yum/ dizinine atmaktadir. İşlemlerimiz bittikten sonra yum clean packages komutunu vererek cache ‘deki paketleri kaldırabiliriz.
Paketleri ve Header ‘ları silmek için
yum clean all
Depolardaki güncellenebilir paketleri görmek için,
yum list updates

Yum ‘u grafik ekrandan kontrol etmek istersek,
Yum Extender yazılımını kullanabiliriz. Yüklemek için yum install yumex

Usb Disk Nasıl?

Linux kurduk, flash disk veya usb disk taktık, peki bunun içeriğini nasıl görebilirim, nasıl yazabilirim. Diski taktıktan sonra root hakkı ile

[root@fedora ~]# tail -f /var/log/messages

cıktısında ;

Mar 3 17:04:38 fedora kernel: SCSI device sda: 4030463 512-byte hdwr sectors (2064 MB)
Mar 3 17:04:38 fedora kernel: sda: Write Protect is off
Mar 3 17:04:38 fedora kernel: sda: assuming drive cache: write through
Mar 3 17:04:38 fedora kernel: SCSI device sda: 4030463 512-byte hdwr sectors (2064 MB)
Mar 3 17:04:38 fedora kernel: sda: Write Protect is off
Mar 3 17:04:38 fedora kernel: sda: assuming drive cache: write through
Mar 3 17:04:38 fedora kernel: sda: sda1
Mar 3 17:04:38 fedora kernel: sd 0:0:0:0: Attached scsi removable disk sda
Mar 3 17:04:38 fedora kernel: sd 0:0:0:0: Attached scsi generic sg0 type 0

baktığımız zaman diskimizi sda1 olarak tanınmış durumda. Gene root hakkı ile

[root@fedora ~]# mkdir /mnt/usb_disk

[root@fedora ~]# mount /dev/sda1 /mnt/usb_disk/
komutları ile diskimizi /mnt/usb_disk altına bağlamış oluyoruz. Dilediğimiz gibi kullabiliriz artık.

İpucu : Sistemimizde haldeamon çalışıyor durum da ise otomatik mount işlemi yapilacaktır.

Mar 3 17:04:39 fedora hald: mounted /dev/sda1 on behalf of uid 500

Görüşmek üzere

Yabancı Bahis Siteleri--